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前言前言



補強設計流程
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結構物耐震補強原則
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強度補強

• 提升構件之彎矩強度及剪力強度

• 增設構件增加結構系統之強度與勁度

翼牆補強 剪力牆補強
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韌性補強

• 提升建築物之非線性變形能力

• 評估結果顯示構件發生剪力破壞，或建築
物變形能力不佳

• 使建築物發揮更多之韌性，消散地震產生
之能量之能量
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補強後評估分析流程

• 初步規劃與設計�決定補強構件數量

• 選定補強位置

• 補強後評估要項

–修改結構分析模型

–修改輔助程式共用輸入檔–修改輔助程式共用輸入檔

• 補強後側推分析

• 得到補強後耐震能力，確認
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初步規劃與設計初步規劃與設計



側推分析

• 以 ETABS軟體分析建築物之容量曲線

• 將建築物之容量曲線轉換為容量震譜求得
性能目標地表加速度

• 最大側力強度 Vbase
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補強構件數量估算
• 補強後側力強度 V*：

• 斷面之抵抗側力強度：

• 補強強度增量：
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• 補強構件數量估算：
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選定補強位置

• 當補強構件數量確定後，應依工程專業將
補強構件配置於適當位置

• 原則上應符合結構平面對稱性，以及降低
對使用性之衝擊
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大漢技術學院江文卿教授提供



補強後評估要項

• 結構分析模型：

新增材料性質

新增補強構件斷面ǵ置換補強構件斷面ǵ移除窗台斜撐

修正非線性鉸性質 (搭配輔助分析程式)

• 輔助程式共用輸入檔：• 輔助程式共用輸入檔：

修正建築物性質模組(建築物樓層重量ǵ模態參與係數)

新增柱斷面模組

修正柱資料模組

修正柱軸力模組

新增柱ǵ梁斷面性質模組

13



補強案例說明補強案例說明



擴柱補強擴柱補強
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擴柱補強簡介

優勢：

注意事項：

1.可提升雙向耐震能力
2.對通風ǵ採光影響較小

1.需注意補強後之走廊淨寬度
2.邊緣處應設置防撞貼條，避免碰撞受傷
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擴柱補強概念

• 將原有柱斷面擴大，提高柱構件之承載能
力與剛度

• 擴柱可增加剪力強度，亦可提升撓曲強度ǵ
軸向強度，對於韌性亦有提升，屬同時增
加強度與韌性之耐震補強工法加強度與韌性之耐震補強工法

• 混凝土強度不佳或強度較低時，採用此種
工法可改善前述問題
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擴柱補強斷面示意圖

15~20cm
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設計與分析之注意事項

• 擴柱之主筋置於四周角隅，使得主筋直通
上下樓層，其餘防裂鋼筋因無受力需求，
遇到梁或樓版時可截斷

• 若採用不貫穿樓版進行設計時，分析模型
之柱上端非線性鉸參數必須調整以原有柱之柱上端非線性鉸參數必須調整以原有柱
之條件計算

• 若屋頂防水層不易處理，可採用不貫穿屋
頂層樓版方式處理
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擴柱之模擬方式

• 同一般鋼筋混凝土柱(雙曲率變形)
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擴柱補強構件數量

• 由分析結果得知，沿走廊方向最大側力強
度 V = 433,503 kgf，初步設計之基底剪力
V*= 564,562 kgf (                     )Ƕ

• 初步設計時假設最小柱軸重為 43,354 kgf

• 原始柱斷面強度為 V0 = 9,109 kgfǶ

V
CDR

V
A

A
V

P

T ×
1

=×=*

• 原始柱斷面強度為 V0 = 9,109 kgfǶ

• 擴柱斷面之撓曲強度：

• 擴柱斷面之剪力強度：
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擴柱補強構件數量
• 擴柱斷面之抵抗側力強度：

• 補強強度增量為：

• 補強構件數量估算求得：

kgfVVV nJbJRCJ 429,57=),min(=

kgfVVV RCJL 410,48==∆ 0-

• 考慮安全性及對稱性下，建議採用 4 根柱子進行
擴柱補強
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擴柱補強位置平面圖

擴柱補強處
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擴柱補強後評估要項

• 結構分析模型：

新增材料性質

新增擴柱斷面ǵ置換補強構件斷面ǵ移除窗台斜撐

修正非線性鉸性質 (搭配輔助分析程式)

• 輔助程式共用輸入檔：• 輔助程式共用輸入檔：

修正建築物性質模組(建築物樓層重量ǵ模態參與係數)

新增柱斷面模組

修正柱資料模組

修正柱軸力模組

新增柱ǵ梁斷面性質模組
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結構分析模型結構分析模型
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1.新增材料性質
• Define → Material Properties
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混凝土強度：280 kgf/cm2

主筋強度：4,200 kgf/cm2

箍筋強度：2,800 kgf/cm2



2.新增擴柱斷面
• Define → Frame Sections
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柱勁度折減0.7倍



3.選定柱置換為擴柱斷面
�選取需置換之柱桿件 (以 C34為例)

� Assign → Frame/Line → Frame Section
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原有 C1S 柱斷面置換為 C4 擴柱斷面

避免因մ除選定補強位置之原有柱而以
繪製柱線方式新增擴柱而改變柱編號，
造成輔助程式讀取錯誤柱資訊



擴柱補強位置
補強前 柱斷面編號：C1S � C4 C1S � C4

擴柱補強後 �移除原有磚牆斜撐
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4.檢視柱軸力資料
• 執行線性靜力分析 Analyze → Run Analysis

• Display → Show Tables
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Frame Output
• Table: Column Forces



4.輸出柱軸力資料
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供輔助程式計算彎矩強度及
剪力強度讀取使用



輔助程式共用輸入檔輔助程式共用輸入檔
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輔助程式共用輸入檔 (一)
• 建築物性質模組 (修正 3 組)
$ Weight    Mode

497900   0.0126
497900   0.0268
432100   0.0352

• 柱斷面模組 (新增 1 組)
$ Name   f_cp f_yl f_yt cover   hoop   spacing   num_hoop TR 

C1L      160    2800   2800    4         3         25           2                 0

單位：kgf-cm
重量增加，模態改變

新增擴柱斷面

C1L      160    2800   2800    4         3         25           2                 0
C4        280    4200   2800    4         3         10           2                 1

• 柱資料模組 (修正 12 組)
$ Name   story   section   shape   H      L      fromBtm

C5        2FL     C1L        C1L 360   300  0
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C4        C4

部分柱置換為擴柱斷面



輔助程式共用輸入檔 (二)

• 軸力資料模組 (全部修正) 單位：kgf-cm

$ Story Column Loc P

RFL C1 0 -4119.07

RFL C1 157.5 -3628.57

RFL C1 315 -3138.07

3FL C1 0 -8929.17

3FL C1 157.5 -8438.67

軸力重新分配
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3FL C1 157.5 -8438.67

3FL C1 315 -7948.17

2FL C1 0 -13536.9

2FL C1 157.5 -13046.4

2FL C1 315 -12555.9

GFL C1 0 -17611.8

GFL C1 52.5 -17448.3

GFL C1 105 -17284.8

： ： ： ：



輔助程式共用輸入檔 (三)

• 柱ǵ梁斷面性質模組 (新增 1 組)

$ Section Properties

C4

60      80

6        4200      6   6   6   6

21.1   2800      7   6   6   7

22      4200      6             6

壓力側

單位：kgf-cm

新增擴柱斷面性質

22      4200      6             6

27      2800      6             6

33      2800      6             6

38      4200      6             6

38.9   2800      7   6   6   7

54      4200      6   6   6   6
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非線性鉸計算與設定非線性鉸計算與設定
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自動計算 RC 柱ǵ梁非線性鉸程式
(COLPH.exe)

• 請問輸出為X方向還是Y方向之非線性鉸
(X:X方向； Y:Y方向) ? (X/Y)：X

• 是否要考慮梁之非線性鉸？ (Y/N)：Y

• 請輸入輔助程式共用輸入檔檔名 (*.txt)：X-RCJ

�檔案名稱可任意命名

• 請輸入 ETABS 結構模型檔檔名 (*.e2k)：
X-RCJ

• 請輸入完成梁ǵ柱非線性鉸計算後之 ETABS 結
構模型檔檔名 (*.e2k)：X-RCJ-colph
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因未變動磚牆，故不須重新執行
Ȭ自動計算磚牆等值斜撐非線性鉸程式 (BWPH.exe)ȭ



補強後耐震能力評估補強後耐震能力評估
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匯入已完成非線性鉸設定之模型檔

• File → Import → ETABS.e2k Text File

開啟X-RCJ-colph.e2k

X-RCJ
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X-RCJ-colph.e2k



檢查是否完成非線性鉸設定

• View → Set Elevation View

以 Y6 Frame 為例

彎矩非線性鉸 剪力非線性鉸 軸力非線性鉸
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非線性側推分析

�執行線性靜力分析

Analyze → Run Analysis

�執行非線性側推分析

Analyze → Run Static 
Nonlinear Analysis
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檢視容量曲線
• Display → Show Static Pushover Curve…  
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輸出容量曲線
• File → Display Tables

Print Tables to File…

匯出檔案 X-RCJ_pd.txt
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最後一點屋頂位移增量若為負值，
應手動移除此列數據



自動計算性能目標地表加速度程式
(PGA.exe)

• 請輸入阻尼修正係數 (既有校舍建築 可設為 0.33)：
0.33 or 1/3

• 請輸入輔助程式共用輸入檔檔名 (*.txt)：X-RCJ

• 請選擇要使用 [1]自行定義或 [2]ETABS 定義或

κ

�檔案名稱可任意命名

κ
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• 請選擇要使用 [1]自行定義或 [2]ETABS 定義或
[3]MIDAS 定義之 P-D 曲線檔：2

• 請輸入 ETABS定義之 P-D 曲線檔檔名 (*.txt)：
X-RCJ_pd

• 請輸入完成性能目標地表加速度計算之文ӷ檔檔名
(*.txt)：X-RCJ_pga



容量曲線與性能曲線
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最大側力強度分析值為 506.35 tf
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由強度準則決定性能目標地表加速度Ap



非線性鉸發展圖
靠走廊側

建築物背面側
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翼牆補強翼牆補強
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翼牆補強簡介

48

優勢：

注意事項：

1.較不影響使用空間以及
走廊通行空間

2.新增牆面可有效ճ用

1.對通風ǵ採光影響較大
2.頂樓及新舊交界面易產生漏水問題



翼牆補強概念

• 於原有柱側邊增設 RC 翼牆，提高增設牆
體方向之耐震能力

• 使原有柱改變為附加 RC 牆體之柱，提高
其強度與勁度

• 當植筋品質不易控制，如混凝土強度過低ǵ• 當植筋品質不易控制，如混凝土強度過低ǵ
鋼筋過密或邊距不足時，不建議採用翼牆
補強
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翼牆補強斷面示意圖

單位：cm
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翼牆補強斷面示意圖

主筋：4200 kgf/cm2

單位：cm

箍筋：2800 kgf/cm2

主筋：4200 kgf/cm

混凝土：280 kgf/cm2

51



設計與分析之注意事項

• 翼牆補強將使得原有梁跨度縮小，應避免於較
短跨度處設置翼牆，以免因破壞機制轉為梁剪
力破壞而降低建築物耐震能力

• 原有梁或柱之混凝土強度偏低，使得植筋效果
不佳，或是原有柱箍筋間距較翼牆水平鋼筋間
距大，造成原有柱與翼牆彼此間之剪力強度差距大，造成原有柱與翼牆彼此間之剪力強度差
異太大，因而受力破壞集中於原有柱

• 考量植筋施工效果及材料變異性，避免過度植
筋以致實際情形與分析結果不符，高估翼牆補
強之效果，建議翼牆鋼筋號數不宜大於
#4(D13)，間距不宜超過15公分
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剪力強度差異不同之影響

53

部位 混凝土強度 水平筋

原有柱 215kgf/cm
2 #3@30

補強翼牆 236kgf/cm
2 #3@20

柱箍筋間距較翼牆水平筋大，
破壞集中於原有柱

部位 混凝土強度 水平筋

原有柱 334kgf/cm
2 #3@20

補強翼牆 567kgf/cm
2 #3@20

柱箍筋間距與翼牆水平筋相同，
破壞較均勻



翼牆之模擬方式
• 翼牆高寬比(H / W)之判斷

� H / W (高瘦型)≧2

→以 RC柱進行模擬

� H / W (矮胖型)＜2

→以 RC牆等值寬柱進行模擬
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翼牆之模擬方式

4040 30
5

0

2
4
原
始
柱

翼牆翼牆

單位：cm
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翼牆補強構件數量

• 由分析結果得知，沿走廊方向最大側力強
度 V = 433,503 kgf，初步設計之基底剪力
V* = 577,404 kgfǶ

• 原始柱斷面強度為 V0 = 9019 kgf，假設柱
軸重為 23,310 kgfǶ軸重為 23,310 kgfǶ

• 翼牆斷面撓曲強度：

• 翼牆斷面之剪力強度：
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翼牆補強構件數量
• 翼牆斷面之抗剪力強度：

• 補強強度增量為：

• 補強桿件數量估算求得：

kgf 088,58=),min(= nWWbWWWW VVV

kgf 070,490 =−=∆ VVV WWn

• 由於翼牆斷面為剪力破壞控制，考慮安全性及對
稱性下，建議採用 6 根柱子進行翼牆補強
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翼牆補強位置平面圖

翼牆補強處

58



結構分析模型結構分析模型
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新增材料性質

• Define → Material Properties
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新增翼牆斷面

• Define → Frame Sections

WW
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ETABS 結構分析模型平面圖

翼牆補強處，將原有柱斷面替換為新的斷面，
以避免柱編號改變
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選定柱置換為翼牆斷面
• 選擇需置換的柱桿件 (以 C34 為例)

• Assign → Frame/Line → Frame Section

原有 C1S 柱斷面
置換為WW 翼牆斷面
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新增翼牆補強位置
補強前

翼牆補強後

64



檢視柱軸力資料
� Analyze → Run Analysis

� Display → Show Tables→ Frame Output → Frame 
Forces → Table: Column Forces
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輸出柱軸力資料

供輔助程式計算彎矩強度讀取使用



輔助程式共用輸入檔輔助程式共用輸入檔
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輔助程式共用輸入檔 (一)

• 建築物性質模組
$ Weight    Mode

488953 0.0112
488953    0.0250
418377    0.0341

• 柱性質模組
$ Name   f_cp f_yl f_yt cover   hoop   spacing   num_hoop TR 

單位：kgf-cm

$ Name   f_cp f_yl f_yt cover   hoop   spacing   num_hoop TR 
C1L      160     2800    2800        4       3           25             2            0
WW      280     4200    2800        4       3           20             2            1

• 柱資料模組
$ Name   story   properties   section   H      L      fromBtm

C5        2FL     C1L             C1L 360   300  0
C5        2FL     WW             WW 360   300  0
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輔助程式共用輸入檔 (二)

• 梁性質模組
$Name     L      f_cp f_yl f_yt cover  hoop  spacing  num_hoop TR

B1D_263  263  160    2800  2800  4      3     25    2   0 

• 梁資料模組
$Name story section

單位：kgf-cm

$Name story section

B36       2FL     B1D_263

B36       3FL     B1D_263

B36       RFL     B1D_263
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輔助程式共用輸入檔 (三)

• 軸力資料模組
$ Story         Column         Loc             P          
RFL C1 0 -4064.92
RFL C1 157.5 -3574.42
RFL C1 315 -3083.92
3FL C1 0 -8875.98
3FL C1 157.5 -8385.48
3FL C1 315 -7894.98

單位：kgf-cm

3FL C1 315 -7894.98
2FL C1 0 -13337.13
2FL C1 157.5 -12846.63
2FL C1 315 -12356.13
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輔助程式共用輸入檔 (四)

• 柱ǵ梁斷面性質模組
WW ----------------------------------斷面名稱

40   24   70   50   110   24 -----斷面幾何尺寸H1 D1 H2 D2 H3 D3 

6       4200        5  5

14     4200        5  5

22     4200        5  5

30     4200        5  5

單位：kgf-cm

46     2800    7  6  6  7

52     2800    6          6

58     2800    6          6

64     2800    7  6  6  7

80     4200        5  5

88     4200        5  5

96     4200        5  5

104   4200        5  5
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非線性鉸計算與設定非線性鉸計算與設定
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自動計算 RC 柱ǵ梁非線性鉸程式
(COLPH.exe)

• 請問輸出為X方向還是Y方向之非線性鉸
(X:X方向； Y:Y方向) ? (X/Y)：X

• 是否要考慮梁之非線性鉸？ (Y/N)：Y

• 請輸入輔助程式共用輸入檔檔名 (*.txt)：X-WW

�檔案名稱可任意命名

• 請輸入 ETABS 結構模型檔檔名 (*.e2k)：
X-WW

• 請輸入完成梁ǵ柱非線性鉸計算後之 ETABS 結
構模型檔檔名 (*.e2k)：X-WW-colph
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因未變動磚牆，故不須重新執行
Ȭ自動計算磚牆等值斜撐非線性鉸程式 (BWPH.exe)ȭ



匯入已完成非線性鉸設定之模型檔

• File → Import → ETABS.e2k Text File

開啟X-WW-colph.e2k

X-WW
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X-WW-colph.e2k



檢查是否完成非線性鉸設定

• View → Set Elevation View

以 Y6 Frame 為例

彎矩非線性鉸 剪力非線性鉸 軸力非線性鉸
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非線性側推分析

�執行線性靜力分析

Analyze → Run Analysis

�執行非線性側推分析

Analyze → Run Static 
Nonlinear Analysis
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建築物容量曲線

輸出容量曲線：

X-WW_pd.txt
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補強前後非線性鉸分布情形(Y2)

補強前

翼牆補強後
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補強後之耐震能力補強後之耐震能力
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自動計算性能目標地表加速度程式
(PGA.exe)

• 請輸入阻尼修正係數 (既有校舍建築 可設為 0.33)：
0.33 or 1/3

• 請輸入輔助程式共用輸入檔檔名 (*.txt)：X-WW

• 請選擇要使用 [1]自行定義或 [2]ETABS 定義或

κ

�檔案名稱可任意命名

κ
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• 請選擇要使用 [1]自行定義或 [2]ETABS 定義或
[3]MIDAS 定義之 P-D 曲線檔：1

• 請輸入 ETABS定義之 P-D 曲線檔檔名 (*.txt)：
X-WW_pd

• 請輸入完成性能目標地表加速度計算之文ӷ檔檔名
(*.txt)：X-WW_pga



容量曲線圖及性能曲線圖
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性能目標：強度準則

第17步產生最大強度
第17步對應的加速度
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性能目標：位移準則

檢查最大基底剪力發生時
(第17步)最大樓層間位移比是
否小於2%：

：

83

RFL：0.48%  <2%

3FL：0.78%  <2%

2FL：0.81%  <2%

故目標性能點由強度準則控制



容量曲線及性能目標地表加速度圖

Vmax = 624.57 tf Ap = 0.283g
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剪力牆補強剪力牆補強
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剪力牆補強簡介

優勢：

注意事項：

1.以較Ͽ的補強量，達到足夠的
耐震需求

2.新增牆面可有效ճ用

對通風ǵ採光影響極大，
應慎選配置地點
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剪力牆補強概念

• 剪力牆具有很高之強度與勁度，對於抵抗
側力需求高之建築物，有極佳之補強效果

• 當建築物有軟弱底層或是質心與剛心有較
大之偏心量時，適合採用此種工法改善抵
抗側力系統平力面之均勻性抗側力系統平力面之均勻性
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設計與分析之注意事項

• 鋼筋混凝土牆具有極高之強度與勁度，配
置時應均勻分散，避免過度集中而產生扭
轉效應

• 建議優先於原有完整磚牆處配置鋼筋混凝
土牆，可減Ͽ因補強造成通風ǵ採光及動土牆，可減Ͽ因補強造成通風ǵ採光及動
線等使用性之衝擊

• 為確保耐震補強之成效以及符合分析結果，
鋼筋混凝土翼牆之厚度不宜太小，建議應
超過20公分，並採用雙層雙向方式配置鋼
筋
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RC牆之等值寬柱模型

• 日本建築學會－鐵筋コソクリ一ト造建物
の耐震性能評価指針」案)‧同解說
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剪力非線性鉸

彎矩非線性鉸

RC牆之等值寬柱模型

等值寬柱

剛性梁
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剪力牆斷面規劃與設計
• 剪力牆面內方向應與建築物弱向平行

• 剪力牆厚度應大於 20 cm，在此考量施工方便性，
牆厚度直接等於梁寬度 24 cm

• 牆筋採用#3，降伏強度 4200 kgf/cm2，混凝土抗
壓強度為 280 kgf/cm2，保護層 4 cm
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#3@15( Double layers of cross)
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15
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剪力牆斷面分析

• 2 根邊界柱軸力 P = 152,657 kgf
• 牆淨高 H = 300 cm
• 牆斷面彎矩強度

kgf 831,539
2

cmkgf 060,974,80

==

=

M
V

M

n
bsw

n -

• 牆斷面剪力強度
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kgf 831,539==
H

Vbsw

kgf 72.417,311cos)1( =′−+= θζ strcvhsu AfKKV

kgf 72.311417) , min( == subSWsw VVV



剪力牆補強構件數量

• 補強前最大側力強度：V = 433,503 kgf

• 強度補強準則：

• 補強構件所提供之側力強度增量：

kgf 087,565=10×503.433×
2148.0

28.0
== 3* V

A

A
V

P

T

• 補強構件所提供之側力強度增量：

• 補強構件數量估算求得：

45.0
*

=
∆

−
=

LV

VV
N

kgf 38.2933802 0 =−=∆ VVV swL
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剪力牆補強位置平面圖

• 基於對稱性原則，建議採用 2 片剪力牆補
強，參考原結構平面圖後選定 2 處剪力牆
配置位置Ƕ
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剪力牆補強處



結構分析模型結構分析模型
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新增材料性質

• Define → Material Properties
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新增剪力牆斷面

24
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新增剪力牆斷面

   

B
C

D 

a
te

r
a

l 

開裂
極限

Lateral Deformation

A

L
a

E 
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新增剪力牆斷面

yslipyfys
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HV

EnIE

HV
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3
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12
δδδ

ν
++=

+
+

×

ETABS Software

(降伏點剪變形)

(降伏點撓曲變形)

(降伏點滑移變形)
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Hδ γ=
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−
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新增剪力牆斷面

yslipyfys

w

y

cgc

y

mA

HV

EnIE

HV
,,,

3
)1(2

12
δδδ

ν
++=

+
+

×

ACI 318-08建議，
剪力牆未開裂
撓曲剛度折減0.7 

m待定係數

10
0



新增剪力牆斷面



新增柱線

• 加入參考線

• 繪製柱線
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新增柱線

建立等值寬柱
C48

移除部分
台度磚牆斜撐

移除邊柱 補強處底端
改固定端
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改固定端



輸出重分配後的軸力

Run analysis �重分配軸力

104



輔助程式共用輸入檔輔助程式共用輸入檔
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重量修正
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軸力修正
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剪力牆軸力

C49

C48

108



• 軸力資料模組
$ AXIAL LOAD

• Story Column Loc P

2FL C48 0       -152657 N 1

剪力牆軸力

單位：kgf-cm

2FL C48 0       -152657

2FL C49 0       -89080

Nu1

Nu2

109



剪力牆性質模組

Nu1

Nu2
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剪力牆性質模組
lw

#3@15

30 30

5
0

300

db=拉力
主筋直徑

dbv=垂直筋直徑
nv=垂直筋根數

dbh=水平筋直徑
nh=水平筋根數

tw=24
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斷面性質($ SECTION PROPERTIES)
SW
$H1 D1 H2 D2 H3 D3
30 50 330 24 360 50
6 2800 7 6 6 7
12 2800 6 6
18 2800 6 6
24 2800 7 6 6 7
35 4200 3 3
50 4200 3 3
65 4200 3 3
80 4200 3 3
95 4200 3 3
110 4200 3 3
125 4200 3 3
140 4200 3 3

單位：kgf-cm

140 4200 3 3
155 4200 3 3
170 4200 3 3
185 4200 3 3
200 4200 3 3
215 4200 3 3
230 4200 3 3
245 4200 3 3
260 4200 3 3
275 4200 3 3
290 4200 3 3
310 4200 3 3
325 4200 3 3
336 2800 7 6 6 7
342 2800 6 6
348 2800 6 6
354 2800 7 6 6 7
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非線性鉸計算與設定非線性鉸計算與設定
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自動計算 RC 柱ǵ梁非線性鉸程式
(COLPH.exe)

• 請問輸出為X方向還是Y方向之非線性鉸
(X:X方向； Y:Y方向) ? (X/Y)：X

• 是否要考慮梁之非線性鉸？ (Y/N)：Y

• 請輸入輔助程式共用輸入檔檔名 (*.txt)：X-SW

�檔案名稱可任意命名

• 請輸入 ETABS 結構模型檔檔名 (*.e2k)：
X-SW

• 請輸入完成梁ǵ柱非線性鉸計算後之 ETABS 結
構模型檔檔名 (*.e2k)：X-SW-colph
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因未變動磚牆，故不須重新執行
Ȭ自動計算磚牆等值斜撐非線性鉸程式 (BWPH.exe)ȭ



自動計算 RC牆非線性鉸程式
• 請問輸出為X方向還是Y方向之非線性鉸(X:X方向；

Y:Y方向) ? (X/Y)：X

• 請輸入輔助程式共用輸入檔檔名 (*.txt)：X-SW

• 請輸入已完成梁ǵ柱及磚牆等值斜撐非線性鉸計
算之 ETABS 結構模型檔檔名 (*.e2k)：算之 ETABS 結構模型檔檔名 (*.e2k)：
X-SW-colph

• 請輸入完成RC剪力牆等值寬柱非線性鉸計算後之
ETABS 結構模型檔檔名 (*.e2k)：
X-SW-done
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匯入已完成非線性鉸設定之模型檔

• File → Import → ETABS.e2k Text File

開啟X-SW-done.e2k

X-SW
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X-SW-done.e2k



檢查剪力牆非線性鉸參數(SW1)
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設定剪力牆非線性鉸位置

Assign shear wall hinge
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剪力牆上方梁設定為 Rigid Beam
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剪力牆上方梁設定為 Rigid Beam

乘10倍
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窗台下方梁非線性鉸設定

窗台斜撐移除後，
梁非線性鉸應重
置Ƕ
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非線性側推分析

�執行線性靜力分析

Analyze → Run Analysis

�執行非線性側推分析

Analyze → Run Static 
Nonlinear Analysis

122



建築物容量曲線
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靠走廊側非線性鉸發展情況(Y2)

補強前

剪力牆補強後
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沿走廊方向容量曲線

輸出容量曲線：

X-SW_pd.txt
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補強後之耐震能力補強後之耐震能力
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自動計算性能目標地表加速度程式
(PGA.exe)

• 請輸入阻尼修正係數 (既有校舍建築 可設為 0.33)：
0.33 or 1/3

• 請輸入輔助程式共用輸入檔檔名 (*.txt)：X-SW

• 請選擇要使用 [1]自行定義或 [2]ETABS 定義或

κ

�檔案名稱可任意命名

κ
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• 請選擇要使用 [1]自行定義或 [2]ETABS 定義或
[3]MIDAS 定義之 P-D 曲線檔：1

• 請輸入 ETABS定義之 P-D 曲線檔檔名 (*.txt)：
X-SW_pd

• 請輸入完成性能目標地表加速度計算之文ӷ檔檔名
(*.txt)：X-SW_pga



執行PGA.exe結果
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$ Pňł Ņłŕł

$Ŕ_a Ŕ_ť ł_Ŧ Ńņŕł_ı Ńņŕł_ŦŲ ŕ_Ŧ ŕ_ı Ń_Ŵ Ń_Ĳ ŇŰųŤŦ ŅiŴű. ł_ű

ı ı.ıııĵĶĵ ı ı ı.ıĶ ı ı ı ı ı ı.ıııķ ı

ı.Ĳĺķĸĳĸ ı.ĸĵĵ ı.ıĸĴĲĴĹ ı ı.ıĶ ı.ĴĺıĲĳĳ ı.ĸĵĳĹĶĸ Ĳ Ĳ ĳĲķĹĴĲ ı.ĺĹĵĴ ı.ıĸĹķĺĲ

ı.ĳĶııĴĶ ı.ĺķĺıĳĲ ı.ĲĳĴĵıĴ ı.ıĲĲĹķĺ ı.ıĶĴĺĲĸ ı.Ĵĺĵĺĳĳ ı.ĸĵĸĵĳĴ Ĳ.ıĳĶĹĶ Ĳ.ıĲĺĶĹ ĳĸĶĶĹĸ Ĳ.ĳĹĳ ı.ĲıĳĶĺĺ

性能目標：強度準則

第13步產生最大強度

第13步對應的加速度

ı.ĳĶııĴĶ ı.ĺķĺıĳĲ ı.ĲĳĴĵıĴ ı.ıĲĲĹķĺ ı.ıĶĴĺĲĸ ı.Ĵĺĵĺĳĳ ı.ĸĵĸĵĳĴ Ĳ.ıĳĶĹĶ Ĳ.ıĲĺĶĹ ĳĸĶĶĹĸ Ĳ.ĳĹĳ ı.ĲıĳĶĺĺ

ı.ĴĶĸĶĹķ Ĳ.ĺĲĸĺĵ ı.ĵĲĲķĺĵ ı.Ĳĳĸķĺ ı.ıĺĳĲĴĹ ı.ĵķĵĶĺĳ ı.ĸĹĵĳĳĶ Ĳ.ĳĸĹĲĲ Ĳ.ĳĲıķĺ ĴĺĵĲĴı ĳ.ĶĴĸĵ ı.ĲĹĳĹĲĵ

ı.ĵĵĴıĺĺ ĳ.ĸĴĳĳĴ ı.ĸĴĸķĺĲ ı.ĲĴĺĳĲ ı.ıĺĶĺĴĺ ı.ĵĺĹĲĵĴ ı.ĸĹĸĳķ Ĳ.ĴıĴĳ Ĳ.ĳĳĺĸ ĵĹĹĴĹĳ Ĵ.ķĲĵĸ ı.ĳĴıĺĸĹ

ı.ĶıĵĹĳĵ Ĵ.ĶĵĺķĴ Ĳ.ĲĳĶĲ ı.ĲķĳĹıĺ ı.ĲıĴĸĳĸ ı.ĶĴĲĺĵĶ ı.ĸĺıĵĹĹ Ĳ.Ĵĵııķ Ĳ.ĳĶĺĴĳ ĶĶķĵĲĶ ĵ.ķĺķĲ ı.ĳĸıĶĺĺ

ı.ĶĵĲĵĳĵ ĵ.ĴķĺĹĳ Ĳ.ĶĶĵĲĸ ı.Ĳĺĺĸķķ ı.ĲĲĶĺĳĴ ı.ĶķĺĺĲĳ ı.ĸĺıĸķĸ Ĳ.Ĵĸĳĺĺ Ĳ.ĳĹĺĹĲ ĶĺķĸĶķ Ķ.ĸĹĲĳ ı.ĳĺĸĴĵĹ

ı.ĶķĺĶķĹ Ķ.ĳķĺĲĶ ĳ.ıĶĴĸĵ ı.ĳĴĵķĹĵ ı.Ĳĳĸĵĵķ ı.ķĲıĲĶĹ ı.ĸĺĲıĲĹ Ĳ.ĵıĵĲ Ĳ.ĴĲĹķĲ ķĳĸĸĸķ ķ.ĺĸĲ ı.ĴĲĺĹĺĴ

ı.ĶĺĲıĲĲ ķ.ıĺĸĹ ĳ.ĶĴĵķ ı.ĳĶĹĹĶ ı.ĲĴĶĵĳĲ ı.ķĵĵĴķĺ ı.ĸĺĲĲĹķ Ĳ.ĵĳĶķĵ Ĳ.ĴĴĹĶĶ ķĶĲĵĲı Ĺ.ıķĸĴ ı.ĴĴĸıĳķ

ı.ķıĵĸĴķ ķ.ĺĳĸĹĳ Ĵ.ıĴıĹĶ ı.ĳĹĵĵĺ ı.ĲĵĴĹĹĳ ı.ķĸĹĺĹķ ı.ĸĺĲĴĶĺ Ĳ.ĵĵĹĵĹ Ĳ.ĴĶĺĸ ķķķĶĴĹ ĺ.ĲķĶĵ ı.ĴĶıĴĸĺ

ı.ķıĺĵĵĸ ĸ.Ĵıĵĸ Ĵ.ĳĶĺķĵ ı.ĳĺĶķĶĳ ı.ĲĵĸĶķĶ ı.ķĺĵĶĲ ı.ĸĺĲĵĴĳ Ĳ.ĵĶĹĵĴ Ĳ.ĴķĹĺĲ ķĸĲĸĴı ĺ.ķķĵ ı.ĴĶĶĶĴĴ

ı.ķĲıĵĳĲ ĸ.ĸıĳıķ Ĵ.ĶıĳıĲ ı.ĴĲĲĸĸĺ ı.ĲĶĳĹĹĸ ı.ĸĲĳĶĹĲ ı.ĸĺĲĶĴĸ Ĳ.ĵĸĳĹ Ĳ.ĴĹĳĳĳ ķĸĳĹıĴ Ĳı.ĲĹĺĸ ı.ĴĶĺķĲ

ı.ķĲıĶĺĵ ĸ.Ĺĸĳĺķ Ĵ.ķıķĴĵ ı.ĴĲĹĶķĵ ı.ĲĶĶĲĳķ ı.ĸĳıĴĵĲ ı.ĸĺĲĶĹ Ĳ.ĵĸĹĹĵ Ĳ.ĴĹĸĹĳ ķĸĳĺĺĵ Ĳı.ĵĲĶĹ ı.ĴķĲĲĹĹ

ı.ķĲıķĲĳ ĸ.ĺıĺıĲ Ĵ.ķĳĹĴķ ı.ĴĲĺĺĹķ ı.ĲĶĶĶĺĶ ı.ĸĳĲĺĸĹ ı.ĸĺĲĶĹĺ Ĳ.ĵĹıĲĲ Ĳ.ĴĹĹĺĺ ķĸĴıĲĵ Ĳı.ĵķĴĶ ı.ĴķĲĶıĹ

129



性能目標：位移準則

最大樓層間位移比是否小於2%：

RFL：0.97%  <2%

3FL：1.04%  <2%

2FL：1.0%  <2%

故目標性能點由強度準則控制
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結論

• 應充分瞭解耐震補強工法之特性與適用時
機，綜合考量建築物之實際情形，再決定
較為合適之耐震補強工法以及補強位置

• 僅須調整補強前分析模型部分內容，即可
進行補強後評估分析，方便使用進行補強後評估分析，方便使用

• 擴柱ǵ翼牆及剪力牆均為傳統且經濟有效
之補強工法，可廣泛運用於老舊建築物耐
震補強
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簡報結束，敬請指教簡報結束，敬請指教
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非線性側推分析之設定非線性側推分析之設定

13
5



地震力豎向分配

• 以側推方向之主控模態進行地震力之豎向
分配

• 各樓層側力之合力通過該樓層之質心

• 以屋頂層質心作為位移之監控點
倒三角形 主控模態∆ ∆

136

技術手冊
第二版

V V

技術手冊
第三版

倒三角形 主控模態roof∆ roof∆

V V



各樓層主控模態

固定GFL層所有節點

137

roof∆

• 固定GFL層所有節點

• 以上部結構之主控模態設定各樓
層之地震力分配

• 執行線性靜力分析
Analyze → Run Analysis



查詢主控模態
• Display → Show Tables

138

Modal Information
• Building Modes
• Building Modal Information



判定主控模態
• 選擇 Modal Participating Mass Ratios

反之，當側推方向為 Y向，
即查詢 UY一欄中最大之
模態參與係數為何？

139

當側推方向為 X向，查詢 UX一欄
發現第 1 模態參與係數達 65.5%，
判定由第 1模態主控

模態參與係數為何？



各樓層模態分量
• 選擇 Building Modes

側推方向為 X向

依此模態之分量

140

設定地震力之豎向分配



• Define → Static Load Cases

非線性側推分析之設定
(Static Load Cases)

新增廣義地震力 PUSHX (X向)
新增廣義地震力 PUSHY (Y向)

14
1

地震力之豎向分配
分別輸入各樓層之[模態分量*質量]
X 向輸入於 FX 欄位
Y向輸入於 FY欄位

不考慮額外偏心



非線性側推分析之設定
(Static Nonlinear/Pushover Case)

• Define → Static Nonlinear/Pushover Case

第一個 Case 為 PUSH1 (力控制)

第二個 Case 為 PUSHX (位移控制)

第三個 Case 為 PUSHY (位移控制)
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查詢質心點座標
• Display → Show Tables

143

Mass Data
• Table: Diaphragm Mass Data



查詢質心點座標
• 各樓層質心座標

質心座標

屋頂層

144

質心座標



繪製屋頂層質心點位
• Draw → Draw Point Objects

1.輸入質心座標
(2690.657, 524.040)

2.指定原點
3.質心點位編號為 44質心座標

145

3.質心點位編號為 44質心座標

44

X = 2690.657

Y = 524.040



定義 PUSH1

選擇力控制

使用預設值即可

依分析方向選擇 UZ

只儲Ӹ分析結果為正之步驟

44

只儲Ӹ分析結果為正之步驟

建議選用ȨUnload Entire Structureȩ

可得較可信的結果

除建築物本身靜載重外
另有設計靜載重 (Live Load)

低矮型建築
不需考慮 P-Delta效應

14
6

Unload Entire Structure



定義 PUSHX

選擇位移控制
預設目標位移量為 0.04*總樓高

依分析方向選擇 UX

只儲Ӹ分析結果為正之步驟

使用預設值即可

由前次分析結果

• 側推方向為 X 方向

質心點位編號

44

只儲Ӹ分析結果為正之步驟

建議選用ȨUnload Entire Structureȩ

可得較可信的結果
低矮型建築
不需考慮 P-Delta效應

由前次分析結果
接續此次分析

Static Load Cases 新增之
地震力側向分佈 PUSHX

負方向側推時，
Scale Factor 改為 -1

14
7

☆等值斜撐應依側推方向予以調整

Unload Entire Structure



依側推方向調整等值斜撐

側推方向

148

等值斜撐

側推方向

等值斜撐



非線性側推分析

解除GFL層所有束縛

�執行線性靜力分析

Analyze → Run Analysis

�執行非線性側推分析
Analyze → Run Static Nonlinear 
Analysis

14
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檢視容量曲線
• Display → Show Static Pushover Curve…  

150



輸出容量曲線
• File → Display Tables

Print Tables to File…

匯出檔案 X_pd.txt

151

最後一點屋頂位移增量為負值，應手動移除此列數據



檢視容量曲線文ӷ檔

側推過程中非線性鉸發展情形

屋頂位移 基底剪力

15
2

15
2



檢核側力強度是否合理
• 執行自動計算 RC 梁ǵ柱 (COLPH.exe) 及磚牆
等值斜撐 (BWPH.exe)非線性鉸程式後出現
colecho或 bwecho文ӷ檔可供檢核

hjxp-colph_colecho.txt hjxp-bwph_bwecho.txtcolecho.txt bwecho.txt

• 分別計算最底層所有垂直構件之抵抗側力
強度並加總，與分析所得之最大強度比較
(如下頁介紹)

• 若分析值接近側力強度總和，則容量曲線
應屬合理

15
3

hjxp-colph_colecho.txt hjxp-bwph_bwecho.txtcolecho.txt bwecho.txt



垂直構件可抵抗之側力強度

判斷該垂直構件係由
彎矩強度或剪力強度控制

加總最底層所有柱之側力
強度

如有Ȩ四面圍束ȩ或
Ȩ三面圍束ȩ磚牆時，
應加計磚牆強度

15
4

強度

柱 +磚牆 + RC牆提供之
強度總和為可抵抗之側力
上限值



最大側力強度之檢核

撓曲強度 剪力強度 破壞模式
可抵抗
側力強度

2FLC1 5697.34 13554.6 撓曲 5697.34

2FLC2 6808.5 15201.2 撓曲 6808.5

: : : : :

155

: : : : :

: : : : :

2FLC47 7644.14 13190.3 撓曲 7644.14

Σ 2FL Column Strength 436401.8 kgf

Vmax obtained by ETABS = 433503.66 kgf < 436401.8 kgf



容量曲線之檢核

上限值：436401.8 kgf

分析值：433503.66 kgf

可判定已得最大基底剪力，
側推分析結果應屬合理

15
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上部結構之屋頂位移
• RFL層位移 - GFL層位移 =上部結構之屋頂位移

RFL層位移 GFL層位移 上部結構之位移

1570 2 4 6 8 10

Roof Displacement (cm)
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上部結構之容量曲線



自動計算性能目標地表加速度程式
(PGA.exe)

• 請輸入阻尼修正係數 (既有校舍建築 可設為 0.33)：
0.33 or 1/3

• 請輸入輔助程式共用輸入檔檔名 (*.txt)：X

• 請選擇要使用 [1]自行定義或 [2]ETABS 定義或

κ

�檔案名稱可任意命名

κ

158

• 請選擇要使用 [1]自行定義或 [2]ETABS 定義或
[3]MIDAS 定義之 P-D 曲線檔：1

• 請輸入 ETABS定義之 P-D 曲線檔檔名 (*.txt)：
X_pd

• 請輸入完成性能目標地表加速度計算之文ӷ檔檔名
(*.txt)：X_pga



性能目標地表加速度

強度準則 位移準則
軸力破壞
準則

Vmax = 433.503 tf

Inter Story Drift

RFL：0.25% < 2%

475年回歸期設計地表加速度 AT = 0.4SDS = 0.28g

一般校舍
Vmax = 433.503 tf

Ap = 0.215g

RFL：0.25% < 2%

2FL：0.65% < 2%

1FL：1.31% < 2%

無

Capacity-Demand Ratio = Ap / AT

Capacity-Demand Ratio = 0.215g / 0.28g = 0.768 < 1
→ 案例校舍需進行耐震補強

15
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設計與分析之注意事項

• 擴柱之主筋置於四周角隅，使得主筋直通
上下樓層，其餘防裂鋼筋因無受力需求，
遇到梁或樓版時可截斷

• 若採用不貫穿樓版進行設計時，分析模型
之柱上端非線性鉸參數必須調整以原有柱之柱上端非線性鉸參數必須調整以原有柱
之條件計算

• 若屋頂防水層不易處理時，可採用不貫穿
屋頂層樓版方式處理
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